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NOTE: This manual assumes that you already have a Unity account, Unity Hub and
the latest LTS (Long Term Support) version of Unity installed on your computer. If you
don’t have Unity installed, refer to this link: https://unity.com/download.

When installing Unity, make sure to check the “Android Build Support” box.

Install Unity 2022.3.0f1 L1s

Add modules Required: 11.77 GB

+| Microsoft Visual Studio Community 2022

+ Android Build Support 439.03 MB 2.05GB
~| OpenJDK 114.82 MB 222.86 MB

»~ | Android SDK & NDK Tools 112 GB 3.03GB
I0S Build Support 46513 MB 1.95 GB
tvOS Build Support 474.91 MB 199 GB

Linux Build Support (IL2CPP) 52.51 MB 217.44 MB

If this option doesn’t come up for you, click “Install Editor” under “Installs” in Unity Hub
and download the version. You will be able to download Android Build Support here.

Unity Hub 3.41

Hub V3.4.2 is now available and will install after restarting.

See Release Notes Restart now Dismisy

Projects Installs Locate Install Editor

Installs



https://unity.com/download
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NOTE:

> Tutorials 1-3 are for your own personal computer.
> Tutorial 4 is for the MakerSpace computer only.
NOTE:

>

*MiddleVR:

MiddleVR is a Unity plugin for multi-display, stereoscopy, cluster rendering
and also VR systems such as Walls, CAVEs etc.

At its core, MiddleVR is a library handling all aspects of multi-display and
cluster rendering, but also optionally adds VR capabilities such as: input devices,
stereoscopy, interactions.

It offers a C# API (application programming interface), and a graphical
user interface to configure a cluster or VR system.

> *MVRManager:

A Unity GameObject with several scripts attached to it. Those scripts
handle all the management of 3D nodes, cameras, viewports, devices, clustering.
The MVRManager will initialize MiddleVR with the specified options,
especially the configuration file. It will create the 3D hierarchy of nodes that
you've specified in MiddleVR Config and the cameras with their respective

viewports.



Tutorial 1 - Installing MiddleVR on your Computer

1. Follow this link: https://www.middlevr.com/2/download-links/ to download
MiddleVR. You will be prompted to make an account and will have to wait for
your account to be approved by an administrator before downloading anything.
You will get an email notifying you of your approval.

2. Once your account has been approved, download MiddleVR. This is free, but it is
only the demo version:

|
mlddlevR HOME BLOG DOWNLOAD DocC DEMOS SUPPORT CONTACT LOG OUT
|

Download links

MiddleVR 2.5.7
Free 7-day trial
Compatible with Unity 2020 LTS to Unity 2023.1

WARNING: You need to upgrade your license with MiddleVR 2.5. Contact your sales
representative.

DOWNLOAD
Changelog

3. Once the download is finished, launch the MiddleVR Installer and follow the
instructions. If you leave everything to the default settings, MiddleVR should be
stored here on your local machine:

C:\Program Files\MiddleVR2

© MiddleVR - Search Resultsin| X +

MiddleVR|

& > ~v A | B > Search Resultsin Program Files >



https://www.middlevr.com/2/download-links/

Tutorial 2 - Configuring your Unity Project and MVRManager for Visbox

a. Create your New Unity Project

1a. Open your Unity Hub and Click “New Project”:

Unity Hub 3.4.1 = (m) X

Hub V3.4.2 is now available and will install after restarting.

Restart now Dismiss
See Release Notes

Projects Pro jects ~ | New project
Installs
Learn

Community MODIFIED EDITOR VERSION

Downloads

2a. Use the 3D template for this project. Make sure to include your name when
naming the project (ie: John Smith - Demo). In this particular example, the project
is just named “Demo” as shown in the screenshots. Click “Create Project”:

Unity Hub 3.4
New project
Editor Version: 2021.3.26f1 (LTS
All templates
New
Core
Sample

Learning

3D
This is an empty 3D project that uses Unity's

2D (URP) built-in renderer.
Core

Read more

3D (URP)
Core

Project name
Your Name - Demo
Runner Game

Core
Location

C:\Users\ \OneDrive\Documents

Cancel Create project




3a. Once the project has been created, the Ul should look something like this:

@ Demo - SampleScene - Windows, Mac, Linux - Unity 2021.3.26f1 Personal <DX11> = o X
File Edit Assets GameObject Component Window Help

Assets

M Packages

b. Import MiddleVR Packages into your Project

1b. Open the Packet Manager: Click on Window > Package Manager:

@ Demo - SampleScene - Windows, Mac, Linux - Unity 2021.3.26f1 Personal <DX11>
File Edit Assets GameObject Component Help
Panels >

Next Window Ctrl+Tab
Previous Window Cirl+Shift+Tab

Layouts >
Search
Unity Version Control

Asset Store

Package Manager

Asset Management
Text
TextMeshPro

General
Rendering
Animation
Audio

Sequencing

Analysis
Al
Ul Toolkit
Visual Scripting

Assets



2b. Click on + and choose Add package from tarball...

O Inspector Package Manager
4l 4 ~ InProject Advanced= o

Add package from disk...
7 | Add package from tarball...
Add package from git URL...

Custom MUnit

High Definition RP

High Definition RP Config

Rider Editor

Shader Graph

3b. Go to where the MiddleVR files are stored. If you didn’t store the files
anywhere specific, they will be located here:
C:\Program Files\MiddleVR2\unity _packages

Click on and open the file with this name: com.middlevr.tgz

e on disk
A~ @ C\Program Files\MiddleVR2\unity_packages

New folder

Name Type

. com.middlevr.hdrp.tgz M TGZ File

‘ com.middlevr.ndi.tgz 202 M TGZ File

‘ com.middlevr.netcode.tgz f 202 TGZ File

. com.middlevr.tgz 5/17/2023 2:48 PM TGZ File
Type: TGZ File

i com.middlevr.urp.tgz 51 MB TGZ File

modified: 5/17/2023 2:48 PM

File name: | com.middlevr.tgz ~| |Package tarba

Cancel




4b. You should see something like this in the package manager after you've
added the package. Close the package manager afterwards:

+- = Q eVR' Manifest
A SampleScene

View in Package Manager

+-P
Features

MiddleVR
Version 2.5.7

Packades - Other Registry Ui
MiddleVR

FdCkages - Unity

Installed From

ogram Fil

Assets

= Assets

M Packages

Remove

c. Add MVRManager into your Project Hierarchy

1c. Go to the “Project” tab > Packages > MiddleVR:

+-
' SampleScene

. All Pre < MiddleVR

w Assets

m NUnit
C tin




2c. Drag and drop the MVRManager object (Packages > MiddleVR >
MVRManager

) into the “Hierarchy” tab:

=RE R ) ame

L 3 v bl -

A SampleScene*

B Project

% Favorites

3c. The project should now be configured to run in a cavspace environment
(Visbox). When Unity is in “Play” Mode, the camera will be appear in this format:
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d. Configure MVRManager

1d. Select MVRManager in the “Hierarchy” and make sure the settings in the
“Inspector” match the picture below:

Untagged -
Open Select Overrides

Transform
B v MvR Manager Script (Script)

Re-apply player settings
Pick configuration file

Config File
A h To Camera
Preview Window
Cluster Properties
Simple Cluster
Simple Cluster Particles
E ugging
or Cluster D

nplat era

able Existing Cameras




e. Add 3D Objects into your Project Hierarchy

1e. To test MiddleVR'’s setup, add three 3D objects to the hierarchy. + > 3D
object > Any shape:

‘= Hierarchy
+ v
Create Empty

Create Empty Child
2 o r=
Effects D Sphere
Light > Capsule
Audio > Cylinder
Video > Plane
ul > Quad
Ul Toolkit 2 Text - TextMeshPro
Camera

Legacy >

Visual Scripting Scene Variables

Ragdoll...

Terrain
Tree
Wind Zone

) Capsule

11
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3e. Click on Main Camera in the “Hierarchy” and adjust it in the project scene so
that the forward most object (the cube in the particular example) is the only
object visible to the main camera:

= a i @

This toolbar can be used to switch from “rotate” to “move” mode. You may need
to rotate the “Main Camera” to get a similar view in this example.

& Came

fy ~
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f. Configure Your 3D Objects to be Grabable

1f. Click on any of the shapes in your “Hierarchy’. In this example the “Cube”
object is selected to be configured:

[‘Eﬁ ¥ Cube

T Tag Untagged r Default

’ Transform

Cube (Mesh Filter)

LI It

74

‘o ¥ Mesh Renderer

-

W v Box Collider

T

(-]

Add Compenent

2f. In the “Inspector” box, Click the “Add Component” button and search “Rigid
Body”. Add it to the “Cube” object:

.,

[:[j' v Cube

v Tag Untagged :r Default

; Transform

Cube (Mesh Filter)

LI It

74

‘s ¥ Mesh Renderer

W v Box Collider

2 92 99
T

-]

Add Component
arig|

Search

A5 Rigidbody




[:[ﬂ v Cube

T Tag Untagged ayer Default

P Transform

Cube (Mesh Filter)

‘o ¥ Mesh Renderer

¥ ~ Box Collider

Rigidbody

None
Discrete

Add Component

3f. In the “Inspector” box, Click the “Add Component” button and search
“‘Actor":

Add Component

14
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4f. Click the “Actor” script and ensure that the settings are the same as in the
below picture:
O Inspector

v Cube

v Tag Untagged ¥ Layer Default

T+

Transform

Cube (Mesh Filter)

7

74

Mesh Renderer
Box Collider
Rigidbody

TR}

!

. Test your Unity Program

1g. Click on the “Play” button at the top of the Ul. You will likely get a message
saying that the license for MiddleVR will expire shortly after the date you installed
it. Just press “OK”:

Unity 20213.26f1 Personal <DX11>
Window  Help

MiddleVR X

Temporary license, expiring : 2023-06-05 18:38
Contact sales@middlevr.com

Assuming that the main camera can only view one object in “Scene” mode and

looks like the picture below in “Game” mode, you have successfully set up a VR
project compatible with the Visbox cave space environment! Make sure to save

all changes (Ctrl + s)
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“Scene” mode vs “Game” mode:

2g. Now that you have a starter project in which you can pick up objects with a
controller, you can now start developing your VR project. If you are still new to
Unity, refer to Unity Learn (https://learn.unity.com/pathways) for tutorials.



https://learn.unity.com/pathways

Tutorial 3 - Exporting and launching your Unity project in MiddieVR

a. Exporting your Unity Project
1a. In Unity, go to File > Build Settings...:

@ Demo - SampleScene - Windows, Mac, Linux - Unit

1Edit Assets GameObject Component W

New Scene Ctrl+N
Open Scene Ctrl+0
Open Recent Scene >
Save Ctrl+S
Save As... Ctrl+Shift+S

Save As Scene Template...

New Project...
Open Project...

Save Project

2 | Build Settings.. | Ctrl+Shift+B
Build And Run Ctrl+B
Exit

2a. If there is nothing in the Scenes in Build box, make sure to click the Add

Open Scenes button. Make sure Windows, Mac, Linux is selected under the
Platform box and that 64-bit (Or anything relating to 64-bit) is selected next to
Architecture. MiddleVR is only compatible with 64-bit builds:

Add Open Scenes
Platform CJ windo Mac, Linux

L_T__] Windows, Mac, Linux Windows

Intel B4-bit
E Dedicated Server

|ﬁ| Android
Andaroid

Default

Asset Import Overrides
No Override

mpr No Override

Player Settings... Build v Build And Run

17
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3a. Click on “Player Settings”:

1 Open Scenes
Platform CJ Windows, Mac, Linux

[g Windows, Mac, Linux Windows

Intel 64 - bit
i Dedicate

' Android

Default

Asset Import Overrides
No Override

No Override

Player Settings... Build And Run

4a. Under “Player” > “Resolution and Presentation”, ensure that you settings
match the photo below:

Player

Icon

Resolution and Presentation

Resolution

Windowed
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Resolution and Presentation

Resolution

en Height
Mac Retina Support
Fun In Background®

Standalone Player Options

‘& Single Si

ble In Baclkagr
w Fullsct

5a. Under “Player” > “Other Settings”, ensure that you settings match the photo
below:

Icon
Resolution and Presentation
Splash Image

Other Settings
Rendering
Gamma

v

v
High Quality
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6a. Press Build and pick a folder on your machine to store the executable file:

Folder

Select Folder | Cancel |

Asset Import Overrides
No Override
No Override

Player Settings... Build v Build And Run

Launching your Project on MiddleVRConfig
NOTE: You can only do this next part on your computer if your free trial has not
expired yet. You will follow this same process on the MakerSpace PC.

1b. Go to "C:\Program Files\MiddleVR2\data\Config\Standard\Default.vrx"
and launch the executable file:

ThisPC > OS(C) » Program Files > MiddleVR2 > data » Config > Standard

Name . Date modified Type
. Defaultvrx 5/26/2022 7:48 PM VRX File

M, MultiDisplay.vrx 5/ 22 7:48 PM VRX File

M, MultiDisplay-Cluster.vrx 5/26/2022 7:48 PM VRX File

M, VirtualCluster.vrx 5/26/2022 7:48 PM VRX File
M, VirtualCluster ServerUnityWindow.vrx 5/ 22 7:48 PM WRX File
M, Warping_Scalable-Display.vrx 5/26/2022 7:48 PM VRX File

M, Warping_Vioso.vnc 5/26/2022 748 PM VRX File
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2b. From here you will be able to add your executable file (Demo.exe in this
example) into MiddleVRConfig by pressing +, adding the file and then pressing
the Run button:

MIDDLEVR - NEW CONFIGURATION [PERMAMENT LICEMNSE]

File WView License Help

COMNAGURATIONS

| mowsE...| | meser |||:|PIN 1N EXPLORER

fo (2) [default]

ADD TO UICK LINKS

NOTE: You will also not be able to test your program on MiddleVRConfig
without a wand and glasses. You will have to put your executable file on a
USB flash drive and load your executable file onto the MiddleVRConfig on
the MakerSpace PC. You can test your program in the MakerSpace cave
space with the necessary equipment.

If you had any trouble following this guide, refer to MiddleVR’s guide here:
https://www.middlevr.com/2/doc/current/TutoUnitySetup.html


https://www.middlevr.com/2/doc/current/TutoUnitySetup.html
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Tutorial 4 - Run “Hello World” Program on MakerSpace Computer and Visbox

NOTE: This tutorial is a guide on how to set up the Visbox projector and
MiddleVRConfig to run the “Hello World” program on the MakerSpace Computer
only. This will not work on your personal computer as the projector, “Hello World
Program” and Visbox are only available in the MakerSpace.

1. Once the MakerSpace computer is powered on, Click on the desktop icon
labeled “PROJS-ON.sh”. This will turn the projector for Visbox on. If Windows is
not already signed on, ask a lab tech for assistance:

vishox
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You should be able to hear the projector power up. Wait a few minutes for the
projector to warm up. Once the Visbox looks like the picture below (the Visbox

logo will be projected on the three vertical walls of the box), you can proceed to
step 2.

a. Click the desktop icon labeled “DTrack3”:

MiddieVE...

b. Click “Connect”:

DTrack3

¥3.0.2 - 2020 3
Copyright (C) 2020, AR.T. GmbH

Advanced Realtime Tracking

Controller
atc-302037002

| Connect |gﬂ1er Controller
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If the DTrack3 Ul looks as it does above, you can proceed to part c.
ONLY IF THE CONNECT BUTTON IS NOT AVAILABLE and instead there is a

button titled “Wake on Lan”, go to the ART controller (the big black machine next
to the Visbox) and switch the power off and back on again:

vishox

Advanced Realtime Tracking

Controller

Exit out of DTrack3 and open it back up again. The connect button should now
be there.
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c. Click “Start”. This will connect the glasses and wand to the Visbox
environment:

W DTrack3 v3.0.2 max. 4 cameras / max. 30 bodies — O x

DTrack3 Hardware Tracking View Tools Help

Start 01 02 03

Mnnmw tab 01

cameras per tab: 4

el Memm B ool pimm @il ek wckn mis spoFip X[mmly[mm]

Flystick Display

Flystick 3 5 6 Jx iy filker  x [mm] y [mm] z[mm] m[deg] ry[deg] rz [deg]

Fingertracking Display
coordinate system ® hand room

hand ID'  hand geometry x [mm] y [mm] z [mm] x [deg] ry [deg] rz [deg]

Event Display

Start or stop measurement Configuration ‘standard' on Controller 'atc-302037002

a. Click the desktop icon labeled “MiddleVRConfig.exe”. This will look
similar to the MiddleVRConfig app that you launched on your computer. If
it asks to run the previous configuration, select “Yes”.

JR.C onfig.ex
JRC onfig.ex
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b. When MiddleVRConfig is open, make sure that the “Hello World” program
is selected. Hit “Run”:

DLEVR - NEW CONFIGURATION [ PRO EDITION]

e View License Help

CONFIGURATIONS

The Visbox environment should now look like this:
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4. You should now be able to test the program with the glasses and wand. You
should be able to walk around in the cube environment.
a. The wand (1) should be in a box labeled “ART” (2)
b. The glasses (3) should be by the computer or plugged into the ART
controller (4) for charging
If you cannot find these two pieces of equipment, ask a lab tech for help.

1. Wand 2. ART Wand Box

ART

Advanced Realtime Tracking




3. Glasses

4. ART Controller

28



IMPORTANT: Follow these steps when you're finished testing.

a. Exit out of MiddleVRConfig

b. Click “Stop” in the DTrack3 program and exit.

P DTrack3 v3.0.2 max. 4 cameras / max, 30 bodies

DTackl_Hardware Iracking View Iools Help

01 02 03

Munlmm tab 01

v

dy 1D Name
(]

Fiter  x[mm] y[mm] z[mm] rx[deg]

active 0.00 0.00

Flystick Display

Flystick

F1

Fingertracking Display

coordinate ® hand room

handID  hand geo y [mm]

Start or stop measurement

c. Click the desktop icon labeled

projector:

PROIS-OFF sh
. ey

Ve =M File
Gize; 62 bytes

1 ||rlr 1

:.-|- J

Froket.site

CrY TN

ry [deg]  rz[deg]

filter  x [mm]

active

2 [mm] m [deg]

170 ®o

per tab: 4 2

wpopip  X[mml y[mm]

yImm]  z[mm] m[deg] ryldeg] rz[deg]

ry [deg]

Configuration ‘standard’ on Contraller

“PROJ-OFF.sh”. This will power down the
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d. You will know that you powered off the projector correctly when the Visbox
looks like this, or how it originally did before the projector was turned on:

6. If you run into any trouble, ask a lab tech for assistance.



